summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 27 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a389f3a..90e3d22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,6 +70,32 @@ AC_ARG_WITH(xorg-module-dir,
inputdir=${moduledir}/input
AC_SUBST(inputdir)
+AC_ARG_WITH(hal_bin_dir,
+ AC_HELP_STRING([--with-hal-bin-dir=DIR],
+ [Directory where HAL binaries where installed [[default=$bindir]]]),
+ [halbindir="$withval"],
+ [halbindir="$bindir"])
+HAL_BIN_DIR=${halbindir}
+AC_SUBST(HAL_BIN_DIR)
+
+AC_ARG_WITH(hal_callouts_dir,
+ AC_HELP_STRING([--with-hal-callouts-dir=DIR],
+ [Directory where HAL expects its callout scripts to be located
+ [[default=$libdir/hal]]]),
+ [halcalloutsdir="$withval"],
+ [halcalloutsdir="$libdir/hal"])
+HAL_CALLOUTS_DIR=${halcalloutsdir}
+AC_SUBST(HAL_CALLOUTS_DIR)
+
+AC_ARG_WITH(hal_fdi_dir,
+ AC_HELP_STRING([--with-hal-fdi-dir=DIR],
+ [Directory where HAL expects its fdi files to be located
+ [[default=$datadir/hal/fdi/policy/20thirdparty]]]),
+ [halfdidir="$withval"],
+ [halfdidir="$datadir/hal/fdi/policy/20thirdparty"])
+HAL_FDI_DIR=${halfdidir}
+AC_SUBST(HAL_FDI_DIR)
+
# Checks for extensions
XORG_DRIVER_CHECK_EXT(RANDR, randrproto)
XORG_DRIVER_CHECK_EXT(XINPUT, inputproto)
@@ -101,4 +127,4 @@ AC_HEADER_STDC
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
-AC_OUTPUT([Makefile shared/Makefile src/Makefile man/Makefile])
+AC_OUTPUT([Makefile shared/Makefile src/Makefile tools/Makefile fdi/Makefile man/Makefile])