summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-09-07 09:36:14 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-09-07 09:36:14 -0700
commit0faf80c838d87102abce4b25783f0118d3c2f8dd (patch)
tree271098b8b29309aebc8cf5e52e0562f2c8db0487 /Makefile.am
parentfde354a19e19730ce90365732480674fd155cf6e (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7052905..4f9559c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,3 +20,14 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = src man
+
+EXTRA_DIST = autogen.sh ChangeLog
+
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog