summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Airlie <airlied@linux.ie>2007-08-04 17:51:06 +1000
committerDave Airlie <airlied@linux.ie>2007-08-04 17:51:06 +1000
commit90946c53d7a4b23d03270ad6da0450759a11de3d (patch)
treeb475942e4dfd07fa5294a670a249517b8ad4b1ff /configure.ac
parente30a145934df8f6a7f71290d6c75e4239f9d52f7 (diff)
ati: add -Wall for gcc
As per luc's "suggestion" in Novell bug. This may generate warnings on 64-bit until we get rid of CARD32
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8b29d8d5..f444afbe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,10 @@ AC_DISABLE_STATIC
AC_PROG_LIBTOOL
AC_PROG_CC
+if test "x$GCC" = "xyes"; then
+ CFLAGS="$CFLAGS -Wall"
+fi
+
AH_TOP([#include "xorg-server.h"])
AC_ARG_WITH(xorg-module-dir,