summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <anholt@freebsd.org>2006-04-25 23:31:56 +0000
committerEric Anholt <anholt@freebsd.org>2006-04-25 23:31:56 +0000
commit44a45bcb82d49349f4fdfae3e4b8f24f98d99b46 (patch)
treedbc0956b9b56d6b9a017cdc1dbbf4609117ad857 /configure.ac
parentcc1825b503ce7e785cbb4611fd177477a1081b6e (diff)
Use a CPPFLAGS with XORG_CFLAGS so that the exa test can actually find its
headers and not fail. Also correct some nearby spelling.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ac238803..92dc830f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,10 +183,12 @@ else
echo "no"
fi
+SAVE_CPPFLAGS="$CPPFLAGS"
+CPPFLAGS="$CPPFLAGS $XORG_CFLAGS"
if test "x$have_exa_h" = xyes; then
- AC_MSG_CHECKING([wether EXA version is at least 2.0.0])
+ AC_MSG_CHECKING([whether EXA version is at least 2.0.0])
AC_PREPROC_IFELSE([AC_LANG_PROGRAM([[
-#include "${sdkdir}/exa.h"
+#include "exa.h"
#if EXA_VERSION_MAJOR < 2
#error OLD EXA!
#endif
@@ -200,6 +202,7 @@ if test "x$have_exa_h" = xyes; then
echo "no."
fi
fi
+CPPFLAGS="$SAVE_CPPFLAGS"
AM_CONDITIONAL(USE_EXA, test "x$USE_EXA" = xyes)