summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <michel.daenzer@amd.com>2012-02-13 10:43:58 +0100
committerMichel Dänzer <michel@daenzer.net>2012-02-13 10:43:58 +0100
commitc66ae235700f5efe64eb168327551b8f1d153c9c (patch)
tree09aeae414dce56f7ff6b0acf04b79d415a945566 /configure.ac
parent7ff277e22c629308915307bbee96eb25ff77f8b9 (diff)
Handle new xorg_list API.
Fixes https://bugs.freedesktop.org/show_bug.cgi?id=45937 Signed-off-by: Michel Dänzer <michel.daenzer@amd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 29f129ac..0083325d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -234,10 +234,18 @@ AC_CHECK_DECL(XSERVER_LIBPCIACCESS,
[#include "xorg-server.h"])
AC_CHECK_HEADERS([list.h],
- [], [],
+ [have_list_h="yes"], [have_list_h="no"],
[#include <X11/Xdefs.h>
#include "xorg-server.h"])
+if test "x$have_list_h" = xyes; then
+ AC_CHECK_DECL(xorg_list_init,
+ [AC_DEFINE(HAVE_XORG_LIST, 1, [Have xorg_list API])], [],
+ [#include <X11/Xdefs.h>
+ #include "xorg-server.h"
+ #include "list.h"])
+fi
+
CPPFLAGS="$SAVE_CPPFLAGS"
AM_CONDITIONAL(USE_EXA, test "x$USE_EXA" = xyes)