summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <michel@tungstengraphics.com>2006-09-30 19:25:20 +0200
committerMichel Dänzer <michel@tungstengraphics.com>2006-09-30 19:25:20 +0200
commitd43ad88fa3913437f6987ab5ab46a38f0cb555a8 (patch)
treeecf6c5c7334fc3a7fd16a8fd65bd24a2c6d582bb /configure.ac
parent146ea328b7962f56c6ab47fbe2adc7561b36189c (diff)
radeon: Add support for page flipping with EXA.
Also use the damage layer directly instead of via shadowfb and blit dirty rectangles to the second page in LeaveServer in order to try and improve the tradeoff between performance and correctness.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a7cdd10f..73ea79de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,6 +91,8 @@ if test "$DRI" != no; then
[have_sarea_h="yes"], [have_sarea_h="no"])
AC_CHECK_FILE([${sdkdir}/dristruct.h],
[have_dristruct_h="yes"], [have_dristruct_h="no"])
+ AC_CHECK_FILE([${sdkdir}/damage.h],
+ [have_damage_h="yes"], [have_damage_h="no"])
fi
AC_MSG_CHECKING([whether to include DRI support])
@@ -110,6 +112,9 @@ if test "$DRI" = yes; then
PKG_CHECK_MODULES(DRI, [libdrm >= 2.0 xf86driproto])
AC_DEFINE(XF86DRI,1,[Enable DRI driver support])
AC_DEFINE(XF86DRI_DEVEL,1,[Enable developmental DRI driver support])
+ if test "$have_damage_h" = yes; then
+ AC_DEFINE(DAMAGE,1,[Use Damage extension])
+ fi
fi
# Note that this is sort of inverted from drivers/ati/Imakefile in