summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOldřich Jedlička <oldium.pro@seznam.cz>2010-09-06 21:14:52 +0200
committerAlex Deucher <alexdeucher@gmail.com>2010-10-07 12:44:32 -0400
commit81360adffb2a66b9a95a38671f9227a9718c9841 (patch)
tree1a2b025855c0bff9b778e29e2947387f925d7c04 /configure.ac
parentadee138f007e26307f1aab7f8fe066150c12e55d (diff)
radeon: proper DRI2 pending events handling when client gone. (v6)
Properly handle asynchronous DRI2 events for disconnected clients. Track client's pending requests and mark them as invalid when the client disconnects. This is based on the version from Alban Browaeys in bug #29065. v1 (Alban Browaeys): Based upon a detailed explanation from Oldřich Jedlička and comments from Christopher James Halse Rogers. on http://lists.x.org/archives/xorg-driver-ati/2010-August/016780.html . v2: Updated version to apply on master. Removed unnecessary client_index field from _DRI2FrameEvent. Added freeing/removing from list to failed paths of radeon_dri2_schedule_wait_msc and radeon_dri2_schedule_swap. v3: Adopt to older xorg-server that doesn't have dixRegisterPrivateKey. v4: Conditional include of list.h, unreachable return removed. v5: Distribute list.h as xorg_list.h, remove xorg-server version check. Use the version from xorg-server when available (checked in configure.ac). v6: Removed xorg_list.h, made DRI2 scheduling features dependent on list.h presence.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index decc46f0..5dbf65a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -233,6 +233,11 @@ AC_CHECK_DECL(XSERVER_LIBPCIACCESS,
[XSERVER_LIBPCIACCESS=yes],[XSERVER_LIBPCIACCESS=no],
[#include "xorg-server.h"])
+AC_CHECK_HEADERS([list.h],
+ [], [],
+ [#include <X11/Xdefs.h>
+ #include "xorg-server.h"])
+
CPPFLAGS="$SAVE_CPPFLAGS"
AM_CONDITIONAL(USE_EXA, test "x$USE_EXA" = xyes)