summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHans de Goede <hdegoede@redhat.com>2014-07-28 15:55:12 +0200
committerMichel Dänzer <michel@daenzer.net>2014-07-30 17:26:36 +0900
commit9b54caf6509a9c02dd17c9c43d6be8f7ddc98054 (patch)
treef1346816478640c6b2a77e6a7eff1ed2519fc54d /configure.ac
parentc4ae0e2cbcc0e2ebf9f13ee92d59b5120254a1dc (diff)
configure: Include xorg-server.h before glamor.h
glamor.h cannot be included without first including xorg-server.h, this also applies to including it from configure snippets. Without this the configure glamor checks fail on systems with the latest glibc, throwing this error: In file included from /usr/include/xorg/misc.h:115:0, from /usr/include/xorg/screenint.h:50, from /usr/include/xorg/scrnintstr.h:50, from /usr/include/xorg/glamor.h:32, from conftest.c:61: /usr/include/xorg/os.h:579:2: error: expected identifier or '(' before '__exten strndup(const char *str, size_t n); ^ This is caused by HAVE_STRNDUP not being set (it is set from xorg-server.h), causing os.h to redefine it. Signed-off-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 101ca17d..e74a0a22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,12 +106,13 @@ AC_ARG_ENABLE(glamor,
[GLAMOR=yes])
if test "x$GLAMOR" != "xno"; then
- AC_CHECK_HEADERS([glamor.h], [GLAMOR_H="yes"], [GLAMOR_H="no"], [])
+ AC_CHECK_HEADERS([glamor.h], [GLAMOR_H="yes"], [GLAMOR_H="no"], [#include "xorg-server.h"])
if test "x$GLAMOR_H" = xyes; then
AC_CHECK_DECL(GLAMOR_NO_DRI3,
[GLAMOR_XSERVER="yes"], [GLAMOR_XSERVER="no"],
- [#include "glamor.h"])
+ [#include "xorg-server.h"
+ #include "glamor.h"])
fi
if test "x$GLAMOR_XSERVER" != xyes; then