summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMichel Dänzer <michel.daenzer@amd.com>2012-06-20 08:40:07 +0200
committerMichel Dänzer <michel@daenzer.net>2012-07-10 17:14:20 +0200
commite9edd2f5002c642b59f028b3ec076d604ae8ce9d (patch)
tree93c7536fb7292c7d042b6571c548f89e3d4945a3 /src/Makefile.am
parent9eac8021f3d33a63156f9f5d43a220e88bb3f8db (diff)
Initial glamor support.
Enable at build time with --enable-glamor and runtime with Option "AccelMethod" "glamor" The most notable lack of functionality is XVideo. Use something like VDPAU for now. Signed-off-by: Michel Dänzer <michel.daenzer@amd.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e857f21a..da94927f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -64,6 +64,13 @@ radeon_drv_la_SOURCES = \
$(RADEON_EXA_SOURCES) \
$(RADEON_KMS_SRCS)
+if GLAMOR
+AM_CFLAGS += @LIBGLAMOR_CFLAGS@
+radeon_drv_la_LIBADD += @LIBGLAMOR_LIBS@
+radeon_drv_la_SOURCES += \
+ radeon_glamor.c
+endif
+
EXTRA_DIST = \
radeon_textured_videofuncs.c \
r600_reg.h \
@@ -88,6 +95,7 @@ EXTRA_DIST = \
radeon_exa_render.c \
radeon_exa_funcs.c \
radeon_exa_shared.h \
+ radeon_glamor.h \
radeon.h \
radeon_probe.h \
radeon_reg.h \