summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 8 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index ca4faf12..c4df2c13 100644
--- a/configure.ac
+++ b/configure.ac
@@ -151,19 +151,19 @@ esac
AC_MSG_CHECKING([whether to include PIO support])
AM_CONDITIONAL(ATIMISC_CPIO, test "x$ATIMISC_CPIO" = xyes)
if test "x$ATIMISC_CPIO" = xyes; then
- echo "yes, PIO"
+ AC_MSG_RESULT([yes, PIO])
else
AC_DEFINE(AVOID_CPIO, 1, [Avoid PIO and use MMIO for atimisc.])
- echo "no, MMIO"
+ AC_MSG_RESULT([no, MMIO])
fi
AC_MSG_CHECKING([whether to include support for non-PCI devices])
AM_CONDITIONAL(ATIMISC_NON_PCI, test "x$ATIMISC_NON_PCI" = xyes)
if test "x$ATI_AVOID_NON_PCI" = xyes; then
- echo "yes, PCI and ISA"
+ AC_MSG_RESULT([yes, PCI and ISA])
else
AC_DEFINE(AVOID_NON_PCI, 1, [Only probe PCI cards; do not probe ISA.])
- echo "no, PCI only"
+ AC_MSG_RESULT([no, PCI only])
fi
AC_MSG_CHECKING([whether to include DGA support])
@@ -185,11 +185,11 @@ AC_DEFINE(USE_XAA, 1, [Build support for XAA])
# Properly handle EXA.
AC_MSG_CHECKING([whether to enable EXA support])
if test "x$EXA" = xyes; then
- echo "yes"
+ AC_MSG_RESULT(yes)
AC_CHECK_FILE([${sdkdir}/exa.h],
[have_exa_h="yes"], [have_exa_h="no"])
else
- echo "no"
+ AC_MSG_RESULT(no)
fi
SAVE_CPPFLAGS="$CPPFLAGS"
@@ -204,11 +204,10 @@ if test "x$have_exa_h" = xyes; then
]])],
[USE_EXA=yes],
[USE_EXA=no])
+ AC_MSG_RESULT($USE_EXA)
+
if test "x$USE_EXA" = xyes; then
- echo "yes."
AC_DEFINE(USE_EXA, 1, [Build support for Exa])
- else
- echo "no."
fi
fi
CPPFLAGS="$SAVE_CPPFLAGS"