summaryrefslogtreecommitdiff
path: root/src/sil164/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/sil164/Makefile.am')
-rw-r--r--src/sil164/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/sil164/Makefile.am b/src/sil164/Makefile.am
new file mode 100644
index 00000000..bb84d036
--- /dev/null
+++ b/src/sil164/Makefile.am
@@ -0,0 +1,16 @@
+# this is obnoxious:
+# -module lets us name the module exactly how we want
+# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
+# _ladir passes a dummy rpath to libtool so the thing will actually link
+# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
+AM_CFLAGS = @XORG_CFLAGS@ @DRI_CFLAGS@
+
+sil164_la_LTLIBRARIES = sil164.la
+sil164_la_LDFLAGS = -module -avoid-version
+sil164_ladir = @moduledir@/drivers
+
+sil164_la_SOURCES = \
+ sil164.c \
+ sil164_module.c \
+ sil164.h \
+ sil164_reg.h