summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2009-10-26 12:54:21 -0400
committerGaetan Nadon <memsize@videotron.ca>2009-11-19 11:28:42 -0500
commit27946998e6ec8537e7137fd453e229d81c092f54 (patch)
treeeef769dcaa00ae418236978cf438b651624f8a03 /Makefile.am
parent50b546f499ae1cafbdf8e890234616733e2e6633 (diff)
Several driver modules do not have a ChangeLog target in Makefile.am #23814
The git generated ChangeLog replaces the hand written one. Update configure.ac to xorg-macros level 1.3. Use XORG_DEFAULT_OPTIONS which replaces four XORG_* macros Update Makefile.am to add ChangeLog target if missing Remove ChangeLog from EXTRA_DIST or *CLEAN variables This is a pre-req for the INSTALL_CMD
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 16f4412..09940ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,3 +20,10 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = src
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog