summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@apple.com>2012-01-09 01:00:40 -0800
committerJeremy Huddleston <jeremyhu@apple.com>2012-01-09 01:00:40 -0800
commit02918fd53434a23a72fe878a90f4ec48ef0e0416 (patch)
tree07fcc7297e8347648ef5b54cbb69564945cc953c /configure.ac
parentbccf37f052748386902112b770b89d81bddfaeb8 (diff)
Don't use XFreeXDGA to determine DGA support
If our server supports DGA and we want to build the dummy driver without it, XFreeXDGA will be defined by the server and will be picked up rather than our configuration option. This change forces us to honor our configuration hoice. Signed-off-by: Jeremy Huddleston <jeremyhu@apple.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d92e22a..6861485 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,7 +61,7 @@ XORG_DRIVER_CHECK_EXT(XV, videoproto)
if test "x$DGA" = xyes; then
XORG_DRIVER_CHECK_EXT(XFreeXDGA, xf86dgaproto)
- AC_DEFINE(XFreeXDGA, 1, [Support DGA extension])
+ AC_DEFINE(USE_DGA, 1, [Support DGA extension])
fi
AC_SUBST([DGA])
AM_CONDITIONAL([DGA], [test "x$DGA" = xyes])