summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAaron Plattner <aplattner@nvidia.com>2017-08-05 21:31:13 +0700
committerAaron Plattner <aplattner@nvidia.com>2017-08-05 16:46:24 -0700
commit87249af5faf85c8d093e910c069faa4db0aee843 (patch)
tree5ede5f857a72933e2b4472f4f7cf0ba1365c2eb1 /configure.ac
parent7c3b090e80a9b364434120262f9bef5686cd2e2e (diff)
Remove DGA support
DGA was so 2004. Signed-off-by: Aaron Plattner <aplattner@nvidia.com> Reviewed-by: Bob Terek <xorg@esoterek.com> Tested-by: Antoine Martin <antoine@nagafix.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 45d61d0..d44f21d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,7 +46,6 @@ AC_PROG_LIBTOOL
AH_TOP([#include "xorg-server.h"])
# Define a configure option for an alternate module directory
-AC_ARG_ENABLE(dga, AS_HELP_STRING([--disable-dga], [Build DGA extension (default: yes)]), [DGA=$enableval], [DGA=yes])
AC_ARG_WITH(xorg-module-dir, [ --with-xorg-module-dir=DIR ],
[ moduledir="$withval" ],
[ moduledir="$libdir/xorg/modules" ])
@@ -57,13 +56,6 @@ AC_SUBST(moduledir)
XORG_DRIVER_CHECK_EXT(RANDR, randrproto)
XORG_DRIVER_CHECK_EXT(RENDER, renderproto)
-if test "x$DGA" = xyes; then
- XORG_DRIVER_CHECK_EXT(XFreeXDGA, xf86dgaproto)
- AC_DEFINE(USE_DGA, 1, [Support DGA extension])
-fi
-AC_SUBST([DGA])
-AM_CONDITIONAL([DGA], [test "x$DGA" = xyes])
-
# Obtain compiler/linker options for the driver dependencies
PKG_CHECK_MODULES(XORG, [xorg-server >= 1.4.99.901] xproto fontsproto $REQUIRED_MODULES)