summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdam Jackson <ajax@benzedrine.nwnk.net>2007-05-31 14:30:10 -0400
committerAdam Jackson <ajax@benzedrine.nwnk.net>2007-05-31 14:30:10 -0400
commitc37fc13ea909a7a1315d3723ccac0e4146b3a0b2 (patch)
tree4779b26aa16fca0e5e96c42f69591fff2e66cff6 /configure.ac
parent0953a855c7d20186a8efb6db4842eb777f6e0e56 (diff)
Add extra GCC warning fu. -Wall cleanup.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6a670d1..8acfd48 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,6 +60,12 @@ AC_ARG_ENABLE(visibility,
[ AMD_CFLAGS="$AMD_CFLAGS -fvisibility=hidden" ],
[ : ])
+if test "x$GCC" = "xyes" ; then
+ GCC_WARNINGS="-Wall -Wstrict-prototypes -Wmissing-prototypes"
+ GCC_WARNINGS="$GCC_WARNINGS -Wmissing-declarations -Wnested-externs"
+fi
+AMD_CFLAGS="$AMD_CFLAGS $GCC_WARNINGS"
+
# Checks for extensions
XORG_DRIVER_CHECK_EXT(RANDR, randrproto)
XORG_DRIVER_CHECK_EXT(RENDER, renderproto)