summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-11-15 19:36:17 -0500
committerMartin-Éric Racine <martin-eric.racine@iki.fi>2011-11-21 10:33:09 +0200
commit23b85b3fcd1439561f0693755a31f7fded50741b (patch)
tree92c8e81f171e7d461cd0deb6f32c596fe44a9bb8 /configure.ac
parente4b771572d7b0797a794340ab8fb8b1db91a5eb1 (diff)
Add conditional build for ztv
Detect the presence of Video4Linux V2 and do not build if missing. The geode driver is no longer Linux only. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b93aa35..3c28bb0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,6 +110,10 @@ if test "x$XSERVER_LIBPCIACCESS" = xyes; then
XORG_CFLAGS="$XORG_CFLAGS $PCIACCESS_CFLAGS"
fi
+# Check for Video4Linux Version 2 (V4L2)
+AC_CHECK_HEADERS([linux/videodev2.h],[v4l2=yes])
+AM_CONDITIONAL(BUILD_ZTV, [test "x$v4l2" = xyes])
+
AC_SUBST([XORG_CFLAGS])
AC_SUBST([moduledir])
AC_SUBST([AMD_CFLAGS])