summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZephaniah E. Hull <warp@agamemnon.b5>2007-06-13 12:28:36 -0400
committerJordan Crouse <jordan.crouse@amd.com>2007-07-06 17:00:26 -0600
commit7bf0627cd001325affbe16118a2f27225179eabd (patch)
tree192177ceff813376034e13e542a4c0c0849eae7b /configure.ac
parentdc23a3168df78424108e8609b250e88c3dd16775 (diff)
From Bernardo Innocenti.
- enable a few GCC warnings - make a few globals const and static - move MGP_RASTER_MODE writes before writes to color registers - compute BPP dynamically in the SolidFill EXA hook Conflicts: configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8acfd48..6332762 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,17 +54,25 @@ AC_ARG_ENABLE(geodegx-panel,
[ ],
[ AMD_CFLAGS="-DPNL_SUP $AMD_CFLAGS" ])
+AC_ARG_ENABLE(werror, AC_HELP_STRING([--enable-werror],
+ [Treat warnings as errors (default: disabled)]),
+ [WERROR=$enableval], [WERROR=no])
AC_ARG_ENABLE(visibility,
AC_HELP_STRING([--enable-visibility],
[Enable GCC visibility optimizations]),
[ AMD_CFLAGS="$AMD_CFLAGS -fvisibility=hidden" ],
[ : ])
-if test "x$GCC" = "xyes" ; then
- GCC_WARNINGS="-Wall -Wstrict-prototypes -Wmissing-prototypes"
- GCC_WARNINGS="$GCC_WARNINGS -Wmissing-declarations -Wnested-externs"
+if test "x$GCC" = "xyes"; then
+ GCC_WARNINGS1="-Wall -Wpointer-arith -Wstrict-prototypes"
+ GCC_WARNINGS2="-Wmissing-prototypes -Wmissing-declarations"
+ GCC_WARNINGS3="-Wnested-externs -fno-strict-aliasing"
+ GCC_WARNINGS="$GCC_WARNINGS1 $GCC_WARNINGS2 $GCC_WARNINGS3"
+ if test "x$WERROR" = "xyes"; then
+ GCC_WARNINGS="${GCC_WARNINGS} -Werror"
+ fi
+ AMD_CFLAGS="$GCC_WARNINGS $AMD_CFLAGS"
fi
-AMD_CFLAGS="$AMD_CFLAGS $GCC_WARNINGS"
# Checks for extensions
XORG_DRIVER_CHECK_EXT(RANDR, randrproto)