summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-11-19 15:33:33 -0500
committerMartin-Éric Racine <martin-eric.racine@iki.fi>2011-11-21 10:33:11 +0200
commitfa0e88bfe00baa648ab3b1184b56f7dc5536aa21 (patch)
treeb87accc5777bd3a3dde813bc4dc8ecf4ba7bff49 /src/Makefile.am
parent03529b7b35fa8d7b5bac277d6abe1caf0557301a (diff)
Move back ztv with geode driver
Now we have a clean separation between CPP flags and C Flags Only the C Flags apply to both geode and ztv driver, however it is not worth doing a per target compilation. Should some flags become mutually exclusive and if we want to have both target in the same makefile, add the incompatible flag on the appropriate target, example: geode_drv_la_CFLAGS = $(AM_CFLAGS) -newCFlag and/or geode_drv_la_CPPFLAGS = $(AM_CPPFLAGS) -newCPPFlag Note that both AM_CFLAGS and AM_CPPFLAGS are picked-up by both geode and ztv driver target. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5df0a32..1f3dfcb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -37,7 +37,7 @@ AM_CFLAGS = $(XORG_CFLAGS) $(CWARNFLAGS) $(M32_CFLAGS)
geode_drv_la_LTLIBRARIES = geode_drv.la
geode_drv_la_LDFLAGS = -module -avoid-version
-geode_drv_ladir = @moduledir@/drivers
+geode_drv_ladir = $(moduledir)/drivers
geode_drv_la_SOURCES = \
cimarron.c \
@@ -142,3 +142,13 @@ EXTRA_DIST = \
\
gx_vga.c \
lx_vga.c
+
+if BUILD_ZTV
+
+ztv_drv_la_LTLIBRARIES = ztv_drv.la
+ztv_drv_la_LDFLAGS = -module -avoid-version
+ztv_drv_ladir = $(moduledir)/drivers
+
+ztv_drv_la_SOURCES = z4l.c
+
+endif BUILD_ZTV