summaryrefslogtreecommitdiff
path: root/ztv/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-11-17 09:32:24 -0500
committerMartin-Éric Racine <martin-eric.racine@iki.fi>2011-11-21 10:33:10 +0200
commit60c3f5f7e9482d29f043504860319aeead7b9a69 (patch)
treeb987ac8035f5f53d972e0076c105e14402dd5be7 /ztv/Makefile.am
parent5f228208cc65348e35aa24b6cddae1df19b67fa5 (diff)
Remove duplicate warning variable and werror option
Use already existing: --enable-strict-compilation Enable all warnings from compiler and make them errors (default: disabled) which, byt the way was broken as it was not implemented in geode. Use already existing CWARNINGFLAGS variable, so there is no need to define GCC_WARNINGS. Both come from util-macros version 1.4 or later. http://cgit.freedesktop.org/xorg/util/macros/tree/xorg-macros.m4.in ?id=03b04a6b5d61aafbd2705f7d29e58e0c92553a4a If you configure with a later version of util-macros you may see new warnings appear as additional flags have been added over the years. You get better support for platforms/compiler differences. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'ztv/Makefile.am')
-rw-r--r--ztv/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/ztv/Makefile.am b/ztv/Makefile.am
index f4aaf1b..4e7b587 100644
--- a/ztv/Makefile.am
+++ b/ztv/Makefile.am
@@ -1,7 +1,7 @@
if BUILD_ZTV
-AM_CFLAGS = $(XORG_CFLAGS) $(AMD_CFLAGS)
+AM_CFLAGS = $(XORG_CFLAGS) $(CWARNFLAGS) $(AMD_CFLAGS)
ztv_drv_la_LTLIBRARIES = ztv_drv.la
ztv_drv_la_LDFLAGS = -module -avoid-version