summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 3 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index 6a1c8c0..c57bd6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,9 +21,9 @@
# Process this file with autoconf to produce a configure script
# Initialize Autoconf
-AC_PREREQ(2.60)
+AC_PREREQ([2.60])
AC_INIT([xf86-video-geode],
- [2.11.21],
+ [2.18.1],
[https://gitlab.freedesktop.org/xorg/driver/xf86-video-geode/-/issues],
[xf86-video-geode],
[http://www.x.org/wiki/GeodeDriver])
@@ -124,38 +124,11 @@ XORG_DRIVER_CHECK_EXT(XV, videoproto)
XORG_DRIVER_CHECK_EXT(DPMSExtension, xextproto)
# Obtain compiler/linker options for the Geode driver dependencies
-PKG_CHECK_MODULES(XORG, [xorg-server xproto fontsproto $REQUIRED_MODULES])
+PKG_CHECK_MODULES(XORG, [xorg-server >= 1.18 xproto fontsproto $REQUIRED_MODULES])
PKG_CHECK_MODULES(XEXT, [xextproto >= 7.0.99.1],
HAVE_XEXTPROTO_71="yes"; AC_DEFINE(HAVE_XEXTPROTO_71, 1, [xextproto 7.1 available]),
HAVE_XEXTPROTO_71="no")
-# Define a configure option to enable/disable XAA support;
-# handles unavailability of XAA since xserver-1.13
-AC_ARG_ENABLE(xaa,
- AS_HELP_STRING([--enable-xaa],
- [Enable legacy X Acceleration Architecture (XAA) [default=auto]]))
-
-AS_IF([test "x$enable_xaa" != "xno"],
- [
- save_CFLAGS=$CFLAGS
- save_CPPFLAGS=$CPPFLAGS
- CFLAGS=$XORG_CFLAGS
- CPPFLAGS="$XORG_CFLAGS"
- AC_CHECK_HEADERS([xaa.h], have_XAA=yes, have_XAA=no)
- CFLAGS=$save_CFLAGS
- CPPFLAGS=$save_CPPFLAGS
-])
-
-AC_MSG_CHECKING([whether to include XAA support])
-
-AS_IF([test "x$have_XAA" = "xyes"],
- [AC_MSG_RESULT([yes])],
- [AS_IF([test "x$enable_xaa" = "xyes"],
- [AC_MSG_ERROR([XAA requested but not found (perhaps building against xserver-1.13 or newer?)])],
- [AC_MSG_RESULT([no])
- ])
-])
-
# Checks for libpciaccess support.
SAVE_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $XORG_CFLAGS"