summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-10-05 10:27:26 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2012-10-05 10:28:21 +0100
commitd717a67ff4a59d0c2cc108cedbecdc20b4c9fb97 (patch)
tree7f996695eef7710bb111a915fd9881430d3f5e68 /configure.ac
parent5b74a2dc5270094810ec0cf8039fd3b3ab0815b5 (diff)
configure: Make rebuilding of the gen4 assembly files explicit
References: https://bugs.freedesktop.org/show_bug.cgi?id=55646 Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c961d856..3ecf7ad4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,8 +81,19 @@ else
fi
fi
-
-PKG_CHECK_MODULES(GEN4ASM, [intel-gen4asm >= 1.2], [gen4asm=yes], [gen4asm=no])
+AC_ARG_ENABLE(gen4asm,
+ AS_HELP_STRING([--enable-gen4asm],
+ [Enable rebuilding the gen4 assembly files [default=no]]),
+ [ASM="$enableval"],
+ [ASM=no])
+
+gen4asm=no
+if test x$ASM != "xno"; then
+ PKG_CHECK_MODULES(GEN4ASM, [intel-gen4asm >= 1.2], [gen4asm=yes], [gen4asm=no])
+ if test x$ASM = "xyes" -a x$gen4asm != "xyes"; then
+ AC_MSG_ERROR([intel-gen4asm support requested but not found])
+ fi
+fi
AM_CONDITIONAL(HAVE_GEN4ASM, test x$gen4asm = xyes)
AC_ARG_ENABLE(udev,