summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJesse Barnes <jbarnes@virtuousgeek.org>2008-08-20 12:11:00 -0700
committerJesse Barnes <jbarnes@virtuousgeek.org>2008-08-20 12:11:00 -0700
commit0de8ca36306c506356e82d500134b4eeb96a6080 (patch)
treebd21f281959f6787a322092f70e61acd90076bcf /configure.ac
parentf26bcb9cb879e2e9ee2b26c95438cf46286c0208 (diff)
parent5eccb5ec7ea78b5800f98decd4216d39b9ebe5ec (diff)
Merge branch 'master' into modesetting-gem
Conflicts: configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 87dad694..e6a2f6fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,7 +96,7 @@ save_CFLAGS="$CFLAGS"
CFLAGS="$XORG_CFLAGS $DRI_CFLAGS $drm_cflags"
CPPFLAGS="$XORG_CFLAGS $DRI_CFLAGS $drm_cflags"
AC_MSG_CHECKING([whether to include DRI support])
-if test x$DRI = xauto; then
+if test x$DRI != xno; then
AC_CHECK_FILE([${sdkdir}/dri.h],
[have_dri_h="yes"], [have_dri_h="no"])
AC_CHECK_FILE([${sdkdir}/sarea.h],
@@ -111,7 +111,9 @@ if test x$DRI = xauto; then
if test "x$DRM_MODE" = xyes; then
AC_DEFINE(XF86DRM_MODE,1,[DRM kernel modesetting])
fi
-
+fi
+AC_MSG_CHECKING([whether to include DRI support])
+if test x$DRI = xauto; then
if test "$have_dri_h" = yes -a \
"$have_sarea_h" = yes -a \
"$have_dristruct_h" = yes; then