summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2008-06-12 13:47:35 -0700
committerEric Anholt <eric@anholt.net>2008-06-12 13:47:35 -0700
commitf07acbdaac95931d184ea2c557edb632e577eb47 (patch)
tree7a45cb9f4bc29f27aec0ae1d3794704f2b2c7140 /configure.ac
parent754df0aa55c4b5f0c3c415ad97d7612504410229 (diff)
Require libdrm 2.4.0 always since we need the bufmgr code.
This lets us remove a lot of conditional compile stuff in the DRI case, as if we're doing DRI and have 2.4.0, we can rely on GEM ioctls existing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 2 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 898c70b8..e62502c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,36 +196,15 @@ if test "x$GCC" = "xyes"; then
-Wnested-externs -fno-strict-aliasing"
fi
+PKG_CHECK_MODULES(DRM, [libdrm >= 2.4.0])
AM_CONDITIONAL(DRI, test x$DRI = xyes)
if test "$DRI" = yes; then
- PKG_CHECK_MODULES(DRI, [libdrm xf86driproto glproto])
+ PKG_CHECK_MODULES(DRI, [xf86driproto glproto])
AC_DEFINE(XF86DRI,1,[Enable DRI driver support])
AC_DEFINE(XF86DRI_DEVEL,1,[Enable developmental DRI driver support])
- PKG_CHECK_MODULES(DRI_MM, [libdrm >= 2.3.1],[DRI_MM=yes], [DRI_MM=no])
- if test "x$DRI_MM" = xyes; then
- AC_DEFINE(XF86DRI_MM,1,[Extended DRI memory management])
- fi
if test "$have_damage_h" = yes; then
AC_DEFINE(DAMAGE,1,[Use Damage extension])
fi
-
- save_CFLAGS="$CFLAGS"
- CFLAGS="$XORG_CFLAGS $DRI_CFLAGS"
- AC_CHECK_TYPE(drm_i915_flip_t,
- [AC_DEFINE(HAVE_I915_FLIP, 1,
- [Have drm_i915_flip_t and related definitions])],
- [], [
-#include <inttypes.h>
-#include <i915_drm.h>
-])
- AC_CHECK_DECL(DRM_IOCTL_GEM_CREATE,
- [AC_DEFINE(HAVE_DRM_GEM, 1,
- [Have DRM Graphics Execution Manager])],
- [], [
-#include <inttypes.h>
-#include <drm.h>
-])
- CFLAGS="$save_CFLAGS"
fi
AM_CONDITIONAL(VIDEO_DEBUG, test x$VIDEO_DEBUG = xyes)