summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2013-01-21 11:41:38 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2013-01-21 11:41:38 +0000
commit5a0bc67ba57cf698e100df617474669ed5d036d6 (patch)
treef8baf4d229de198faa25db6b863e9b693674f983 /configure.ac
parent208ca91a31182e8ddad36e6a735c725362cbd071 (diff)
sna: New execbuffer flags for lut-handle and fast-relocs are upstream
Now the flags are upstream, we can rely on runtime tests as the interface is now frozen. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 0 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 317bc6de..cb1496b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -291,24 +291,6 @@ if test "x$USERPTR" = xyes; then
AC_DEFINE(USE_USERPTR,1,[Assume USERPTR support])
fi
-AC_ARG_ENABLE(fast-reloc,
- AS_HELP_STRING([--enable-fast-reloc],
- [Enable use of "fast reloc" (experimental) [default=no]]),
- [FASTRELOC="$enableval"],
- [FASTRELOC=no])
-if test "x$FASTRELOC" = xyes; then
- AC_DEFINE(USE_FASTRELOC,1,[Assume "fast reloc" support])
-fi
-
-AC_ARG_ENABLE(handle-lut,
- AS_HELP_STRING([--enable-handle-lut],
- [Enable use of "handle LUT" (experimental) [default=no]]),
- [HANDLE_LUT="$enableval"],
- [HANDLE_LUT=no])
-if test "x$HANDLE_LUT" = xyes; then
- AC_DEFINE(USE_HANDLE_LUT,1,[Assume "handle LUT" support])
-fi
-
AC_ARG_ENABLE(async-swap,
AS_HELP_STRING([--enable-async-swap],
[Enable use of asynchronous swaps (experimental) [default=no]]),