summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-11-08 15:56:13 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2012-11-08 17:06:29 +0000
commit85ba7e96268dbb8da4bb34078333695a451c6570 (patch)
tree8c38b63abbd5537eb3ad34aef44fdeba348bfaad /configure.ac
parent93d8dddbb92431d6e2c48a17b71cac9f7047902e (diff)
sna: Experiment with using reloc.handle as an index into the execbuffer
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9ea1e3c6..ce3b0073 100644
--- a/configure.ac
+++ b/configure.ac
@@ -301,6 +301,15 @@ if test "x$FASTRELOC" = xyes; then
AC_DEFINE(USE_FASTRELOC,1,[Assume "fast reloc" support])
fi
+AC_ARG_ENABLE(handle-lut,
+ AS_HELP_STRING([--enable-handle-lut],
+ [Enable use of "handle LUT" (experimental) [default=no]]),
+ [HANDLE_LUT="$enableval"],
+ [HANDLE_LUT=no])
+if test "x$HANDLE_LUT" = xyes; then
+ AC_DEFINE(USE_HANDLE_LUT,1,[Assume "handle LUT" support])
+fi
+
AC_ARG_ENABLE(async-swap,
AS_HELP_STRING([--enable-async-swap],
[Enable use of asynchronous swaps (experimental) [default=no]]),