summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-06-18 21:26:58 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2012-06-18 21:29:51 +0100
commit92e1693e5fb3a1dd89fca5e5ecc660e2de78f9cd (patch)
tree7ea8665579647a3243ae92c8c6e70b7171a69ea5 /configure.ac
parentd2312c8f958002e54ddcb834f37916f4b46ac291 (diff)
sna: Validate cpu/gpu damage never overlaps
References: https://bugs.freedesktop.org/show_bug.cgi?id=50477 Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0b93a2f6..604db7de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -318,8 +318,12 @@ fi
if test "x$DEBUG" = xmemory; then
AC_DEFINE(DEBUG_MEMORY,1,[Enable memory debugging])
fi
+if test "x$DEBUG" = xpixmap; then
+ AC_DEFINE(DEBUG_PIXMAP,1,[Enable pixmap debugging])
+fi
if test "x$DEBUG" = xfull; then
AC_DEFINE(DEBUG_MEMORY,1,[Enable memory debugging])
+ AC_DEFINE(DEBUG_PIXMAP,1,[Enable pixmap debugging])
AC_DEFINE(HAS_DEBUG_FULL,1,[Enable all debugging])
CFLAGS="$CFLAGS -O0 -ggdb3"
fi