summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2013-04-16 11:55:23 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2013-04-16 11:56:17 +0100
commitddd3cc4ed6ac9b69f178147b49628b7a7f3f3104 (patch)
treec069978cac43936d66fdc9fda03474f53a320bc9 /configure.ac
parentf0b6ae2cfb811a8c234634c878800ca1fb95703f (diff)
sna: Add VALGRIND_CFLAGS whilst compiling with --enable-valgrind
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fa825072..9411e174 100644
--- a/configure.ac
+++ b/configure.ac
@@ -450,6 +450,7 @@ else
VG=auto
fi
fi
+have_valgrind=no
if test "x$VG" != xno; then
PKG_CHECK_MODULES(VALGRIND, [valgrind], have_valgrind=yes, have_valgrind=no)
AC_MSG_CHECKING([whether to include valgrind support])
@@ -462,6 +463,7 @@ if test "x$VG" != xno; then
fi
AC_MSG_RESULT([$have_valgrind ($VG)])
fi
+AM_CONDITIONAL(VALGRIND, test x$have_valgrind = xyes)
if test "x$DEBUG" = xsync; then
AC_DEFINE(DEBUG_SYNC,1,[Enable synchronous rendering for debugging])
fi