summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2006-03-01 13:01:52 -0800
committerEric Anholt <anholt@leguin.anholt.net>2006-04-06 15:55:05 -0700
commit2538cbeb5014e40280a3ae782a755512b1dc85fa (patch)
tree3457a6b98b66f68d51897c1f9ba4a4c3378c0ac1 /configure.ac
parent7746da3b346968ab8d2534fc158d026da67cc7b5 (diff)
Enable -Wall on GCC, and do a cleanup of existing warnings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 665b76a7..5626c4e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,10 @@ AC_DISABLE_STATIC
AC_PROG_LIBTOOL
AC_PROG_CC
+if test "x$GCC" = "xyes"; then
+ CFLAGS="$CFLAGS -Wall"
+fi
+
AH_TOP([#include "xorg-server.h"])
AC_ARG_WITH(xorg-module-dir,