summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2011-09-09 12:36:32 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2011-09-09 15:26:04 +0100
commit2e1bf7e1b44db16d0c322f17535fc6a6fa07353b (patch)
tree70efbdf147b8ba55d18535e2adf94d6ca03a2624 /configure.ac
parentf73cd955e760064f57f414dce5f39e43022e4ea6 (diff)
sna: Record git-tree used for compilation
Hopefully, I have all the dependencies correct for auto-updating and should continue to work with tarballs... The next step is to perhaps include it in the usual version number, perhaps as patch level? Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fbd46a72..089fbdb0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,14 @@ m4_ifndef([XORG_DRIVER_CHECK_EXT],
LT_PREREQ([2.2])
LT_INIT([disable-static])
+# Are we in a git checkout?
+dot_git=no
+if test -e .git; then
+ AC_DEFINE(HAVE_DOT_GIT, 1, [Are we in a git checkout?])
+ dot_git=yes
+fi
+AM_CONDITIONAL(HAVE_DOT_GIT, test x$dot_git = xyes)
+
PKG_CHECK_MODULES(GEN4ASM, [intel-gen4asm >= 1.2], [gen4asm=yes], [gen4asm=no])
AM_CONDITIONAL(HAVE_GEN4ASM, test x$gen4asm = xyes)