summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2007-06-13 13:34:26 -0700
committerEric Anholt <eric@anholt.net>2007-06-13 13:34:26 -0700
commit420e41e7921d3cc07c784fd17936ec8a675f3b20 (patch)
tree27fe5a37b67c0b55e183c53597230272739b5405 /configure.ac
parent51612e5ac3ddfb2bb172c58f2dfff9631093b69c (diff)
Revert "Replace failure-prone configure test for fresh libdrm with a simple ifndef."
This reverts commit c2b130354aecffbeb2a2d23c7371461feaf5766a. Sadly, a non-working DRM_IOCTL_I915_FLIP already existed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 53d23ed1..da9fd3f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -189,6 +189,14 @@ if test "$DRI" = yes; then
if test "$have_damage_h" = yes; then
AC_DEFINE(DAMAGE,1,[Use Damage extension])
fi
+
+ save_CFLAGS="$CFLAGS"
+ CFLAGS="$DRI_CFLAGS"
+ AC_CHECK_TYPE(drm_i915_flip_t,
+ [AC_DEFINE(HAVE_I915_FLIP, 1,
+ [Have drm_i915_flip_t and related definitions])],
+ [], [#include <i915_drm.h>])
+ CFLAGS="$save_CFLAGS"
fi
AM_CONDITIONAL(VIDEO_DEBUG, test x$VIDEO_DEBUG = xyes)