summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2006-06-26 14:53:10 +0200
committerEric Anholt <anholt@FreeBSD.org>2006-06-26 14:53:10 +0200
commit5111b883480a5a9cc82200f2684cba67b515aa73 (patch)
tree61374e0a1115dd8d5edbf2316cf7ea86323f9880 /configure.ac
parentf2967a2f5f47b636b2445fa69dbc3ec79e065c90 (diff)
Turn on extra warning flags for GCC, and clean up the resulting fallout.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a5f8e77f..82d3e55f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,6 +89,18 @@ if test x$DRI = xauto; then
fi
AC_MSG_RESULT([$DRI])
+dnl Use lots of warning flags with GCC
+
+WARN_CFLAGS=""
+
+if test "x$GCC" = "xyes"; then
+ WARN_CFLAGS="-Wall -Wpointer-arith -Wstrict-prototypes \
+ -Wmissing-prototypes -Wmissing-declarations \
+ -Wnested-externs -fno-strict-aliasing"
+fi
+
+CFLAGS="$CFLAGS $WARN_CFLAGS"
+
AM_CONDITIONAL(DRI, test x$DRI = xyes)
if test "$DRI" = yes; then
PKG_CHECK_MODULES(DRI, [libdrm >= 2.0 xf86driproto])