summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2013-07-29 23:49:08 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2013-07-29 23:49:08 +0100
commitcf7d36455fc43e88697f4fb8fd865f3259ba0d1a (patch)
tree433d8a98bfe30fc09138e39825ff4dcfec317176 /configure.ac
parentd7465ece29c9ae665a5a9f5bdac764a19062786e (diff)
intel: Suppress some extremely noisy warnings
Warning about redundant declarations within the xorg headers hides genuine warnings in our own code - disable them until the headers are cleaned up. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a004ef33..6b2c161f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,11 @@ m4_ifndef([XORG_MACROS_VERSION],
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
+# And disable a few very noisy warnings
+XORG_TESTSET_CFLAG([NOWARNFLAGS], [-Wno-cast-qual])
+XORG_TESTSET_CFLAG([NOWARNFLAGS], [-Wno-redundant-decls])
+AC_SUBST(NOWARNFLAGS)
+
# Require X.Org server macros (i.e. XORG_DRIVER_CHECK_EXT) to check for required modules
m4_ifndef([XORG_DRIVER_CHECK_EXT],
[m4_fatal([must install xorg-server macros before running autoconf/autogen.