summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZhenyu Wang <zhenyu.z.wang@intel.com>2008-05-06 13:52:22 +0800
committerZhenyu Wang <zhenyu.z.wang@intel.com>2008-05-07 11:11:16 +0800
commitad02b795f5aa01d1e5b85f3661ae574e898fe41e (patch)
treed5364be038eb02e61365ac0902b82fc2fefd9677 /configure.ac
parent8103c3c404500fa21079bd04530fd8ee836474f4 (diff)
Only check xvmc lib when xvmc is enabled.
Don't check xvmc lib if user has already wanted to disable it. Fix fdo bug #15762. (cherry picked from commit c81a4687fca80bf7367d7f0e9a00a6a09737c5bb)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 23939c9d..7401451b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,7 +82,7 @@ XORG_DRIVER_CHECK_EXT(XF86DRI, xextproto x11)
XORG_DRIVER_CHECK_EXT(DPMSExtension, xextproto)
# Checks for pkg-config packages
-PKG_CHECK_MODULES(XORG, [xorg-server xproto xvmc fontsproto $REQUIRED_MODULES])
+PKG_CHECK_MODULES(XORG, [xorg-server xproto fontsproto $REQUIRED_MODULES])
sdkdir=$(pkg-config --variable=sdkdir xorg-server)
# Checks for libraries.
@@ -225,17 +225,21 @@ if test "$VIDEO_DEBUG" = yes; then
AC_DEFINE(VIDEO_DEBUG,1,[Enable debug support])
fi
-AC_MSG_CHECKING([whether to include XvMC support])
if test "$XVMC" = auto; then
XVMC="$DRI"
fi
if test "$XVMC" = yes && test "$DRI" = no; then
AC_MSG_ERROR([XvMC can't be enabled without DRI])
fi
+if test "$XVMC" = yes; then
+ PKG_CHECK_MODULES(XVMCLIB, [xvmc], [XVMC=yes], [XVMC=no])
+fi
+AC_MSG_CHECKING([whether to include XvMC support])
AC_MSG_RESULT([$XVMC])
AM_CONDITIONAL(XVMC, test x$XVMC = xyes)
if test "$XVMC" = yes; then
AC_DEFINE(ENABLE_XVMC,1,[Enable XvMC support])
+ AC_SUBST([XVMCLIB_CFLAGS])
fi