summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZhenyu Wang <zhenyuw@linux.intel.com>2009-06-25 15:30:04 +0800
committerZhenyu Wang <zhenyuw@linux.intel.com>2009-06-30 11:12:12 +0800
commit9fb34012f667e37f480085696ef9c2632d6eb7e1 (patch)
tree8b4b1b969b9f9ef605d53087585308592d96c780 /configure.ac
parent488acc4595bb7f40130afcb8bcb05656ff3ae82c (diff)
Add new compiled shader program for IGDNG
Also check intel-gen4asm tool here for new -g option, which is required to compile new programs. Signed-off-by: Zhenyu Wang <zhenyuw@linux.intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 397336ca..486fed72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,15 @@ AC_PROG_CC
AM_PROG_CC_C_O
AC_CHECK_PROG(gen4asm, [intel-gen4asm], yes, no)
+
+if test x$gen4asm != xno; then
+ intel-gen4asm -g 5 src/render_program/exa_sf.g4a > /dev/null
+
+ if test "$?" != "0"; then
+ echo "Error: Require new intel-gen4asm with -g option!"
+ exit 1
+ fi
+fi
AM_CONDITIONAL(HAVE_GEN4ASM, test x$gen4asm = xyes)
AC_CHECK_HEADERS(sys/mman.h)