summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2013-07-22 22:01:22 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2013-07-22 22:01:22 +0100
commit8d94f030c6af64f82d495a835a3b962480c068e7 (patch)
treef9680da2d248386424b06a2a1f59714e9a40a574 /configure.ac
parent0498e0c38d0b04d89020e61c13b250150ec19c3a (diff)
configure: Fix enabling of DRI2
After setting it to false, we then need to set DRI2 to true after we detect the headers. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0fcde50d..2b6ce916 100644
--- a/configure.ac
+++ b/configure.ac
@@ -424,7 +424,7 @@ fi
DRI2=no
if test "x$enable_dri" != "xno"; then
- PKG_CHECK_MODULES(DRI2, [dri2proto >= 2.6],, DRI2=no)
+ PKG_CHECK_MODULES(DRI2, [dri2proto >= 2.6], DRI2=yes, DRI2=no)
dridriverdir=`$PKG_CONFIG --variable=dridriverdir dri`
if test "x$dridriverdir" != "x"; then
AC_DEFINE_DIR(DRI_DRIVER_PATH, dridriverdir, [Default DRI driver path])