summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2006-08-10 13:49:43 -0700
committerEric Anholt <eric@anholt.net>2006-08-10 13:49:43 -0700
commit975e60261088dee124b329d28c64e508bce1f90b (patch)
tree798dd479dc0979311aa9aef18900f30235cd752b /configure.ac
parent820e9a22fdb759cbdaac4a488322825bc0908b0d (diff)
Bug #7829: Fix reported driver version.
The driver now reports itself as the PACKAGE_VERSION from autoconf. The DRI DDX -> client interface version is dissociated from this so that we can do appropriate major/minor versioning of the interface that's not tied to the package version. Bumped the i830 ddx dri version patchlevel to note the fix in the previous commit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 74e676ba..edd5d7b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,16 @@ AC_INIT([xf86-video-i810],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
xf86-video-i810)
+AC_DEFINE_UNQUOTED([INTEL_VERSION_MAJOR],
+ [$(echo $PACKAGE_VERSION | sed -e 's/^\([[0-9]]\)\.[[0-9]]\.[[0-9]]/\1/')],
+ [Major version])
+AC_DEFINE_UNQUOTED([INTEL_VERSION_MINOR],
+ [$(echo $PACKAGE_VERSION | sed -e 's/^[[0-9]]\.\([[0-9]]\)\.[[0-9]]/\1/')],
+ [Minor version])
+AC_DEFINE_UNQUOTED([INTEL_VERSION_PATCH],
+ [$(echo $PACKAGE_VERSION | sed -e 's/^[[0-9]]\.[[0-9]]\.\([[0-9]]\)/\1/')],
+ [Patch version])
+
AC_CONFIG_SRCDIR([Makefile.am])
AM_CONFIG_HEADER([config.h])
AC_CONFIG_AUX_DIR(.)