summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <michel@tungstengraphics.com>2007-03-12 13:01:00 +0100
committerMichel Dänzer <michel@tungstengraphics.com>2007-03-12 13:01:00 +0100
commitba55ff15df974197bebd871e28bb96d817ae41c7 (patch)
tree44a2c87115c656f06b7b1692e0feb9c3e836ca6d /configure.ac
parentc4a23c5ef8ce56ee0fe547fbc7c6623c021f801b (diff)
Fix attempt to flip pages back to normal when the last 3D window disappears.
When this succeeds, 2D rendering does not have to be synchronized to back buffers until the next 3D window appears.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fbb9c647..52cc07bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,6 +180,14 @@ if test "$DRI" = yes; then
if test "$have_damage_h" = yes; then
AC_DEFINE(DAMAGE,1,[Use Damage extension])
fi
+
+ save_CFLAGS="$CFLAGS"
+ CFLAGS="$DRI_CFLAGS"
+ AC_CHECK_TYPE(drm_i915_flip_t,
+ [AC_DEFINE(HAVE_I915_FLIP, 1,
+ [Have drm_i915_flip_t and related definitions])],
+ [], [#include <i915_drm.h>])
+ CFLAGS="$save_CFLAGS"
fi
AM_CONDITIONAL(VIDEO_DEBUG, test x$VIDEO_DEBUG = xyes)