summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2014-05-20 15:37:13 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2014-06-02 08:32:11 +0100
commit67b37332bd45dd4cea297107bfdc9df21984fdcd (patch)
tree45a68f5b9658bee3866d14682e338b47a2134d09 /configure.ac
parent9cf6cd9726ed5ba73bb8c38c06f7b5c78706309b (diff)
intel-virtual-output: Add DRI3 xfer path
Just as proof-of-principle. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8b0bd30c..353f942a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,6 +255,11 @@ fi
if test "x$tools" != "xno"; then
ivo_requires="xinerama xrandr xdamage xfixes xcursor xtst xrender xext x11 pixman-1"
PKG_CHECK_MODULES(IVO, [$ivo_requires], [ivo="yes"], [ivo="no"])
+ PKG_CHECK_MODULES(IVO_DRI3, [xcb-dri3 xcb-sync x11-xcb xshmfence x11], [ivo_dri3="yes"], [ivo_dri3="no"])
+ if test "x$ivo_dri3" = "xyes"; then
+ IVO_CFLAGS="$IVO_CFLAGS $IVO_DRI3_CFLAGS -DDRI3"
+ IVO_LIBS="$IVO_LIBS $IVO_DRI3_LIBS"
+ fi
AC_CHECK_HEADER([sys/timerfd.h], [], [ivo="no"])
if test "x$ivo" = "xno"; then
if test "x$tools" = "xyes"; then