summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2014-06-07 09:07:16 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2014-06-07 09:12:52 +0100
commit717e00facd27696c6b8a1a6c343b2f94bfa2b59b (patch)
tree796042dc2584a2114ecc3a1d1bb48ca28778196c /configure.ac
parentdcb64b55092ea3da6adf357305d65b58d848db7b (diff)
sna: Allow TearFree to be enabled by default via configure
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9aeeb813..8e3dbf79 100644
--- a/configure.ac
+++ b/configure.ac
@@ -668,6 +668,16 @@ AC_MSG_RESULT($accel)
xp_msg=""
+AC_ARG_ENABLE(tear-free,
+ AS_HELP_STRING([--enable-tear-free],
+ [Enable use of TearFree by default [default=no]]),
+ [TEARFREE="$enableval"],
+ [TEARFREE="no"])
+if test "x$TEARFREE" = "xyes"; then
+ AC_DEFINE(TEARFREE,1,[Enable "TearFree" by default])
+ xp_msg="$xp_msg TearFree"
+fi
+
AC_ARG_ENABLE(rendernode,
AS_HELP_STRING([--enable-rendernode],
[Enable use of render nodes (experimental) [default=no]]),