summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2013-09-08 16:36:33 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2013-09-08 16:38:58 +0100
commitf25235a854e211f73cc44821b9a7c2a1a4092155 (patch)
treef0cd3ad447f5c9ea39c1d99ba8d1528e372ab271 /configure.ac
parent0ceba648211009a464e46855a52737219ab9b534 (diff)
configure: Only assert DRI2 requirements not met if the DRI2 package is missing
The new error message was added in commit ea30967245707ca4825de154e589a83dc605dae0 [2.99.902] Author: Chris Wilson <chris@chris-wilson.co.uk> Date: Fri Sep 6 22:54:48 2013 +0000 configure: Disable UXA build without DRI2 Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 500eb109..0a63121e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -394,13 +394,14 @@ fi
AC_MSG_CHECKING([whether to include DRI2 support])
AM_CONDITIONAL(DRI2, test "x$DRI2" = "xyes")
AC_MSG_RESULT([$DRI2])
-if test "x$enable_dri" = "xyes" -a "x$KMS" = "xyes"; then
- AC_MSG_ERROR([DRI2 requested but prerequisites not found])
-fi
if test "x$DRI2" != "xno"; then
AC_DEFINE(HAVE_DRI2,1,[Enable DRI2 driver support])
dri_msg="$dri_msg DRI2"
else
+ if test "x$enable_dri" = "xyes" -a "x$KMS" = "xyes"; then
+ AC_MSG_ERROR([DRI2 requested but prerequisites not found])
+ fi
+
# UXA doesn't build without DRI2 headers, too late to fix
UXA=no
fi