summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-11-07 17:41:20 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2012-11-08 08:58:58 +0000
commit120fa0ef8d04f5e82e5f7a0636033d3d96efa1e8 (patch)
tree810a70bed24229f15ab2f69b7df9feeaaff2c25c /configure.ac
parentb7d2fcf47a9569d0944097a8be60ca3be72b42f6 (diff)
sna: Support a fast no relocation changed path
x11perf -copywinwin10 on gm45 with c2d L9400: before: 553,000 op/s after: 565,000 op/s Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8ddf40b8..9ea1e3c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -292,6 +292,15 @@ if test "x$USERPTR" = xyes; then
AC_DEFINE(USE_USERPTR,1,[Assume USERPTR support])
fi
+AC_ARG_ENABLE(fast-reloc,
+ AS_HELP_STRING([--enable-fast-reloc],
+ [Enable use of "fast reloc" (experimental) [default=no]]),
+ [FASTRELOC="$enableval"],
+ [FASTRELOC=no])
+if test "x$FASTRELOC" = xyes; then
+ AC_DEFINE(USE_FASTRELOC,1,[Assume "fast reloc" support])
+fi
+
AC_ARG_ENABLE(async-swap,
AS_HELP_STRING([--enable-async-swap],
[Enable use of asynchronous swaps (experimental) [default=no]]),