summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2014-06-09 17:04:47 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2014-06-09 21:47:24 +0100
commitc1154ae1070806b8da1aad29f75c9659f2a403df (patch)
tree2b95558730a647e79d68e7654e95bd6cede597d3 /configure.ac
parentbb2d5e3696b52835770a62a951f7ed7e51291f88 (diff)
configure: Allow disabling control over the backlight
Some OS prefer to control the backlight themselves through another daemon and so do not want X interfering. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8e3dbf79..fdadf4b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,11 +69,20 @@ case $host_os in
;;
esac
+AC_ARG_ENABLE(backlight,
+ AS_HELP_STRING([--disable-backlight],
+ [Enable control over the backlight [default=yes]]),
+ [backlight="$enableval"],
+ [backlight="yes"])
+if test "x$backlight" = "xyes"; then
+ AC_DEFINE(USE_BACKLIGHT, 1, [Enable control of the backlight])
+fi
+
AC_ARG_ENABLE(backlight-helper,
AS_HELP_STRING([--disable-backlight-helper],
[Enable building the backlight helper executable for running X under a normal user [default=auto]]),
[backlight_helper="$enableval"],)
-AM_CONDITIONAL(BUILD_BACKLIGHT_HELPER, [test "x$backlight_helper" = "xyes"])
+AM_CONDITIONAL(BUILD_BACKLIGHT_HELPER, [test "x$backlight" = "xyes" -a "x$backlight_helper" = "xyes"])
if test "x$backlight_helper" = "xyes"; then
tools_msg="$tools_msg xf86-video-intel-backlight-helper"
AC_DEFINE(USE_BACKLIGHT_HELPER, 1, [Enable use of the backlight helper interfaces])