summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2010-12-21 23:03:21 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2010-12-21 23:03:21 +0000
commite8db77e019e19ace48592b2f6d96af6baa9a228e (patch)
tree2ab3def94c924ba7b7c7949d0a04b3ca072c981b /configure.ac
parentebb7aca66785730737bc739624006e55d43dfe1b (diff)
Revert "Suggest where to find xorg-macros in case it's missing"
I failed my reading comprehension and didn't spot that the help strings pointed to two separate downstream packages. Thanks to Carl Worth for pointing out my mistake. This reverts commit ebb7aca66785730737bc739624006e55d43dfe1b.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 5eaf0e5f..e6517e65 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,17 +35,17 @@ AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
-m4_define(xorg_macros_help,
-[[must install xorg-macros 1.8 or later before running autoconf/autogen.
-Either install xorg-macros from source,
-git://anongit.freedesktop.org/xorg/util/macros, or try
-"apt-get install xutils-dev" or "yum install xorg-x11-util-macros".]])
-m4_ifndef([XORG_MACROS_VERSION], [m4_fatal(xorg_macros_help)])
-m4_ifndef([XORG_DRIVER_CHECK_EXT], [m4_fatal(xorg_macros_help)])
-
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen.
+ Try "apt-get install xutils-dev" or "yum install xorg-x11-util-macros"])])
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
+# Require X.Org server macros (i.e. XORG_DRIVER_CHECK_EXT) to check for required modules
+m4_ifndef([XORG_DRIVER_CHECK_EXT],
+ [m4_fatal([must install xorg-server macros before running autoconf/autogen.
+ Try "apt-get install xserver-xorg-dev" or "yum install xorg-x11-server-devel"])])
+
# Initialize libtool
AC_DISABLE_STATIC
AC_PROG_LIBTOOL