summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2013-01-20 10:14:21 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2013-01-20 10:15:30 +0000
commit9329d8755981989ccbe66df6085fbab7c809a2c6 (patch)
tree48b3252389bf8e1ecbbe9ef49133e403ac2147cf /configure.ac
parentc9263f192e2f85dd961bc1c4e9ca8180db874517 (diff)
sna: Make DEBUG_SYNC a configure option
As it is advisable to combined the synchronous rendering debug option with other debugging options, it is more convenient to make it into a configure option: --enable-debug=sync Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ff264623..e93fd886 100644
--- a/configure.ac
+++ b/configure.ac
@@ -418,6 +418,9 @@ if test "x$DEBUG" != xno; then
AC_DEFINE([HAVE_VALGRIND], 1, [Use valgrind intrinsics to suppress false warnings])
fi
fi
+if test "x$DEBUG" = xsync; then
+ AC_DEFINE(DEBUG_SYNC,1,[Enable synchronous rendering for debugging])
+fi
if test "x$DEBUG" = xmemory; then
AC_DEFINE(DEBUG_MEMORY,1,[Enable memory debugging])
fi