summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKenneth Graunke <kenneth@whitecape.org>2014-03-06 13:12:32 -0800
committerChris Wilson <chris@chris-wilson.co.uk>2014-03-13 15:04:59 +0000
commitcbcc1b6190ab733c9ab11543af4a4eb1890225e4 (patch)
tree412f50a80e78e59e48fe7bc3d6a344380c216d4c /configure.ac
parentc1d7abadbb0009e9f2b9d8d3744d4ae5c13a1c8f (diff)
uxa: Enable BLT acceleration on Broadwell.
This supports solid, copy, put_image, and get_image acceleration via the BLT engine. RENDER acceleration (composite) and Xv would be piles of work, which is not worth doing since SNA exists, and Glamor is coming. Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 18c1d2b4..7bf07aef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -312,13 +312,14 @@ if test "x$SNA" != "xno"; then
AC_CHECK_HEADERS([sys/sysinfo.h], AC_CHECK_MEMBERS([struct sysinfo.totalram], [], [], [[#include <sys/sysinfo.h>]]))
fi
+uxa_requires_libdrm=2.4.52
AC_ARG_ENABLE(uxa,
AS_HELP_STRING([--enable-uxa],
- [Enable Unified Acceleration Architecture (UXA) [default=yes]]),
+ [Enable Unified Acceleration Architecture (UXA) [default=auto]]),
[UXA="$enableval"],
[UXA=auto])
if test "x$UXA" = "xauto"; then
- if ! pkg-config --exists 'libdrm_intel >= 2.4.29'; then
+ if ! pkg-config --exists "libdrm_intel >= $uxa_requires_libdrm"; then
UXA=no
fi
if ! pkg-config --exists 'pixman-1 >= 0.24.0'; then
@@ -327,7 +328,7 @@ if test "x$UXA" = "xauto"; then
fi
if test "x$UXA" != "xno"; then
AC_DEFINE(USE_UXA, 1, [Enable UXA support])
- PKG_CHECK_MODULES(DRMINTEL, [libdrm_intel >= 2.4.29])
+ PKG_CHECK_MODULES(DRMINTEL, [libdrm_intel >= $uxa_requires_libdrm])
required_pixman_version=0.24
UXA=yes
fi