summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-06-11 09:51:41 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2012-06-11 12:19:57 +0100
commit392e33a62d729c64c57699505220b4029e015470 (patch)
treebc533d54a03b68be0a4a8bb8e01f0b84d012b911 /configure.ac
parent4e984b79cce038ba5026d8bdd93dec9b5a6ced8a (diff)
sna: Instrument memory/bo allocations for monitoring over time
Hide it behind --enable-debug=memory to avoid incurring the cost for everybody. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a9e8fa5a..0b93a2f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -315,7 +315,11 @@ if test "x$DEBUG" != xno; then
AC_DEFINE([HAVE_VALGRIND], 1, [Use valgrind intrinsics to suppress false warnings])
fi
fi
+if test "x$DEBUG" = xmemory; then
+ AC_DEFINE(DEBUG_MEMORY,1,[Enable memory debugging])
+fi
if test "x$DEBUG" = xfull; then
+ AC_DEFINE(DEBUG_MEMORY,1,[Enable memory debugging])
AC_DEFINE(HAS_DEBUG_FULL,1,[Enable all debugging])
CFLAGS="$CFLAGS -O0 -ggdb3"
fi