summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-10-07 10:46:19 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2012-10-07 10:49:07 +0100
commit4d2dba0ba70c2b217a777243e8a89f7a5c5349a9 (patch)
tree7014d9ec082fa4e166d266253c8ff8946e0c6a5e /configure.ac
parent249051d90fb0ab0bea5561a04ee2a5d0a2238ff1 (diff)
Use path for intel-gen4asm derived from pkg-config
As we use pkg-config to determine whether to use intel-gen4asm, we should also use it to locate the right version of intel-gen4asm to use. This allows the user to install the assembler in a non-standard path for cross-builds and similar. Reported-by: Josh Tripplet <josh@freedesktop.org> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=55646 Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3ecf7ad4..79bba832 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,6 +93,15 @@ if test x$ASM != "xno"; then
if test x$ASM = "xyes" -a x$gen4asm != "xyes"; then
AC_MSG_ERROR([intel-gen4asm support requested but not found])
fi
+ if test x$gen4asm = "xyes"; then
+ AC_MSG_CHECKING([path to use for intel-gen4asm])
+ INTEL_GEN4ASM="`pkg-config intel-gen4asm --variable=exec_prefix`/bin/intel-gen4asm"
+ if ! test -e "$INTEL_GEN4ASM"; then
+ AC_MSG_ERROR([intel-gen4asm enabled, but not found. Tried '$INTEL_GEN4ASM'.])
+ fi
+ AC_MSG_RESULT([$INTEL_GEN4ASM])
+ AC_SUBST([INTEL_GEN4ASM])
+ fi
fi
AM_CONDITIONAL(HAVE_GEN4ASM, test x$gen4asm = xyes)