summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2009-10-15 13:48:56 -0700
committerEric Anholt <eric@anholt.net>2009-10-19 10:36:30 -0700
commit3e8f2eae3a586aa29be4858698e666e0ec778cea (patch)
tree2e201d5a336ea008ff827b2ae35e82ddc88bf0be /configure.ac
parent38ab403d7a1c461c8ac65a056bee2dd5c7f2f58e (diff)
XVMC: Use XCB DRI2 instead of cargo-culting our own copy of Xlib stuff. (v2)
v2: Incorporate comments from Jamey on device name handling and extension detection.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b1e9a71f..19dbf13c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,7 +155,9 @@ if test "$VIDEO_DEBUG" = yes; then
fi
if test "$XVMC" = yes; then
- PKG_CHECK_MODULES(XVMCLIB, [xvmc xext xfixes dri2proto], [XVMC=yes], [XVMC=no])
+ PKG_CHECK_MODULES(XVMCLIB,
+ [xvmc xext xfixes dri2proto x11-xcb xcb-dri2 xcb-aux],
+ [XVMC=yes], [XVMC=no])
fi
AC_MSG_CHECKING([whether to include XvMC support])
AC_MSG_RESULT([$XVMC])