summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-12-16 23:04:55 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2012-12-16 23:04:55 +0000
commit5b0572503eab235bc7eff20d369241330c41e630 (patch)
tree2ff5b23d0f961a56e8dce8b1734db9226ba106c4 /configure.ac
parent805f78addf3ffb36c736df680806cf722b18fea9 (diff)
sna: Enable support for opting out of the kernel CS workaround
Keeping a set of pinned batches in userspace is considerably faster as we can avoid the blit overhead. However, combining the two approaches yields even greater performance, as fast as without either w/a, and yet stable. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 93544372..e1530195 100644
--- a/configure.ac
+++ b/configure.ac
@@ -282,6 +282,15 @@ if test "x$accel" = xnone -a "x$UMS_ONLY" != "xyes"; then
AC_MSG_ERROR([No default acceleration option])
fi
+AC_ARG_ENABLE(pinned-batches,
+ AS_HELP_STRING([--enable-pinned-batches],
+ [Enable use of "pinned batches" (experimental) [default=no]]),
+ [PINNED="$enableval"],
+ [PINNED=no])
+if test "x$PINNED" = xyes; then
+ AC_DEFINE(USE_PINNED_BATCHES,1,[Assume "pinned batches" support])
+fi
+
AC_ARG_ENABLE(userptr,
AS_HELP_STRING([--enable-userptr],
[Enable use of userptr (experimental) [default=no]]),