summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulien Cristau <jcristau@debian.org>2009-06-11 17:15:04 +0200
committerJulien Cristau <jcristau@debian.org>2009-06-11 17:51:38 +0200
commit6d062e9e9fc4ac92a5dc2941b4ed0251a1dc6e11 (patch)
treedc2981f158d4240b89447c5c0ba7652fb4732b15 /configure.ac
parent9d3c3b056c1d4da6ef7afd3f71a5994fad810632 (diff)
Fix xvmc build
If we don't find xext.pc, disable xvmc instead of failing configure Also add dependencies on xfixes and dri2proto (src/xvmc/dri2.h includes <X11/extensions/Xfixes.h> and <X11/extensions/dri2tokens.h>).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c40818f9..0864d7c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,8 +152,7 @@ if test "$VIDEO_DEBUG" = yes; then
fi
if test "$XVMC" = yes; then
- PKG_CHECK_MODULES(XVMCLIB, [xvmc], [XVMC=yes], [XVMC=no])
- PKG_CHECK_MODULES(XEXT, [xext])
+ PKG_CHECK_MODULES(XVMCLIB, [xvmc xext xfixes dri2proto], [XVMC=yes], [XVMC=no])
fi
AC_MSG_CHECKING([whether to include XvMC support])
AC_MSG_RESULT([$XVMC])